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£vÄ Gs
Register Number

PART - III

Po¨ö£õÔ°¯À / COMPUTER SCIENCE

(Vocational Component under General Stream)

( uªÌ ©ØÖ® B[Q» ÁÈ / Tamil & English Versions)

÷|µ® : 3 ©o ] [ ö©õzu ©v¨ö£sPÒ : 150
Time Allowed : 3 Hours ] [Maximum Marks : 150

AÔÄøµ : (1) AøÚzx ÂÚõUPÐ® \›¯õP £vÁõQ EÒÍuõ Gß£uøÚ
\›£õºzxU öPõÒÍÄ®. Aa_¨£vÂÀ SøÓ°¸¨¤ß, AøÓU
PsPõo¨£õÍ›h® EhÚi¯õPz öu›ÂUPÄ®.

(2) P¸¨¦ ø©°øÚ ©mk÷© GÊxÁuØS® AiU÷PõikÁuØS®
£¯ß£kzu ÷Ásk®.  £h[PÒ ÁøµÁuØS ö£ß]À
£¯ß£kzuÄ®.

Instructions : (1) Check the question paper for fairness of printing.  If there is any lack of
fairness, inform the Hall Supervisor immediately.

(2) Use Black ink to write and underline and pencil to draw diagrams.
SÔ¨¦ : (i) £Sv&I &À EÒÍ AøÚzx (£ÀÁøP ÂÚõUPÒ) ÂÚõUPÐUS®

(1 •uÀ 75 Áøµ) uÛ÷¯ ÁÇ[P¨£mkÒÍ OMR ÂøhzuõÎÀ ©mk÷©
Âøh¯ÎUP ÷Ásk®. (OMR ÂøhzuõÎÀ EÒÍ AÔÄøµø¯U
PõsP)

(ii) ÂÚõzuõÒ Á»x £UP ‰ø»°À uµ¨£mkÒÍ ‘ ’ (dash) SÔ±k G¢u
GsoUøP°À EÒÍ÷uõ AuØ÷PØ£ OMR ÂøhzuõÎÀ  (1)
AÀ»x  (2) AÀ»x  (3) AÀ»x  (4) GÝ®
Pmh® P¸¨¦ ø©°ÚõÀ {Ç¼h¨£h ÷Ásk®.

(iii) ÂÚõ GsPÒ 1 •uÀ 75 Áøµ EÒÍ ÂÚõUPÐUS Âøh¯ÎUP
JxUP¨£mh ÷|µ® •uÀ 75 {ªh[PÒ BS®.

(iv) £Sv II ©ØÖ® £Sv III&À EÒÍ ÂÚõUPÐUS (76 •uÀ 110 Áøµ)
•ußø© ÂøhzuõÎÀ Âøh¯ÎUP ÷Ásk®.

Note : (i) Candidates should answer all the questions in PART - I (Objective type) (1 to 75)
in the separate OMR Answer Sheet supplied.  (Refer instructions given in the
OMR Answer Sheet).

(ii) The number of the sign ‘ ’ (dash) as found in the right - hand top corner of the
Question Paper i.e.  (1) or  (2) or  (3) or  (4)
should be shaded in the OMR Answer Sheet using Black ink.

(iii) Time allotted for answering question numbers 1 to 75 is first 75 minutes.
(iv) PART-II and PART-III questions (76 to 110) should be answered in the main

answer-book.

No. of Printed Pages : 24
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£Sv & I / PART - I

öPõkUP¨£mh |õßS ÂøhPÎÀ ªPÄ® HØ¦øh¯ Âøh°øÚ
÷uº¢öukzx SÔ±mkhß Âøh°øÚ²® ÷\ºzx GÊxP.

Choose the most suitable answer from the given four alternatives and write the option
code and the corresponding answer.

1. C++ &À int &uµÂÚzvß Áµ®¦ ©v¨¦ :

(A) −32678 to 32767 (B) −32678 to 32768

(C) −32767 to 32767 (D) −32768 to 32767

In C++, the range of int data type is :

(A) −32678 to 32767 (B) −32678 to 32768

(C) −32767 to 32767 (D) −32768 to 32767

2. Real Audio/Real Video £iÁ® G¢u Bsk E¸Áø©UP¨£mhx ?

(A) 1995 (B) 1982 (C) 1992 (D) 1985

In which year the Real Audio/Real Video format was developed ?

(A) 1995 (B) 1982 (C) 1992 (D) 1985

3. G¢u \õÂ ÷\º©õÚzøu¨ £¯ß£kzv uµÄzuÍ AmhÁønø¯ ÷\ªUP»õ® ?

(A) Ctrl + N (B) Ctrl + A (C) Ctrl + S (D) Ctrl + F

Which key combination is used to save a table in database ?

(A) Ctrl + N (B) Ctrl + A (C) Ctrl + S (D) Ctrl + F

4. GIF GzuøÚ Pso Ásnzumk Aø©¨¤ØSÒ Ah[Q¯x ?

(A) 16 (B) 256 (C) 8 (D) 32

GIF is limited to how many bit palette ?

(A) 16 (B) 256 (C) 8 (D) 32

5. Gx Ãmi¼¸¢u£i÷¯ Cøn¯zvß ÁÈ¯õP Á[Q ÷\øÁPøÍ ~Pµ
Áõ´¨£ÎUQÓx ?

(A) AøÇ¨¦uÂ ø©¯® (B) ªß & PØÓÀ

(C) ªß & Pøha ö\»Ä (D) ªß & Á[Qa ÷\øÁ

Which permits banking from the comfort of the home by using internet facility ?

(A) Call center (B) e-Learning

(C) e-Shopping (D) e-Banking

75x1=75
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6. ìhõº BL¤ì øµmh›À  Format → Page PmhøÍø¯z ÷uºÄ ö\´uõÀ G¢u
Eøµ¯õhÀ ö£mi ÷uõßÖ® ?

(A) uø»¨¦ (B) £UP Aø©¨¦ (C) ÁiÅmhÀ (D) AiUSÔ¨¦

In StarOffice Writer, which dialog box is opened when we select Format → Page
command ?

(A) Header (B) Page Style (C) Format (D) Footer

7. C++ &À ¤ßÁ¸® Ao°ß AÍÄ GßÚ ?

float y[6][4];

(A) 24 ø£mkPÒ (B) 48 ø£mkPÒ

(C) 10 ø£mkPÒ (D) 96 ø£mkPÒ

In C++, what will be the size of the array ?

float y[6][4];

(A) 24 bytes (B) 48 bytes

(C) 10 bytes (D) 96 bytes

8. C++ &À, uµÄ EÖ¨¦PÒ CÆÁõÖ AøÇUP¨£kQÓx :

(A) EÖ¨¦a ö\¯ØTÖPÒ (B) £s¦UTÖPÒ

(C) ÁÈ•øÓPÒ (D) ö£õ¸ÒPÒ

In C++, data members are also called :

(A) member functions (B) attributes

(C) methods (D) objects

9. \mh¨¦Ó©õÚ •øÓ°À J¸ Po¨ö£õÔ •øÓø©°À AÀ»x ¤øn¯zvÀ
~øÇÁøu GÆÁõÖ AøÇUP»õ® ?

(A) E›ø©°À»õ |P»õUP® (B) |a_ {µÀ

(C) Aµs EøhzuÀ (D) Po¨ö£õÔ SØÓ®

Which is illegal access to the network or computer system ?

(A) Piracy (B) Virus

(C) Cracking (D) Computer Crime
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10. öuõhUP Põ» {µ»õUP ö©õÈPÎÀ EÒÏmk, öÁÎ±mkz uµÄU TÖPÒ
CÆÁõÖ øP¯õÍ¨£mhÚ  :

(A) uµÄ (B) ö£õ¸Ò (C) ©õÔPÒ (D) CÚUSÊ

In the early programming languages, the input and output data items were represented
as :

(A) data (B) object (C) variables (D) class

11. ìhõºBL¤ì øµmh›À ¤ßÁ¸ÁÚÁØÖÒ Gx A»[Põµ GÊzx
ÁøP¯õS® ?

(A) Times New Roman (B) Symbol

(C) Wingdings (D) Fajita

In StarOffice Writer, which of the following is the decorative font ?

(A) Times New Roman (B) Symbol

(C) Wingdings (D) Fajita

12. BUQ°ß ö£¯º Guß ö£¯µõP÷Á C¸UP ÷Ásk® ?

(A) ö£õ¸Ò (B) ö\¯ØTÖ (C) CÚUSÊ (D) ÁÈ•øÓ

The name of the constructor must be same as that of what ?

(A) object (B) function (C) class (D) method

13. {PÌzxuÀ \ßÚÀ vøµ°À ø©¯a \õÍµ¨ ¤›ÂÀ GzuøÚ uzuÀ (Tabs)
SÔPÒ EÒÍÚ ?

(A) |õßS (B) BÖ (C) ‰ßÖ (D) I¢x

In Presentation window, how many tabs are there in the center pane ?

(A) Four (B) Six (C) Three (D) Five

14. C++ &À CÁØÖÒ Gx ö\¯ØSÔ uµÄ Dº¨¦ AÀ»x uµÄ ö£Ö® ö\¯ØSÔ
BS® ?

(A) < (B) > (C) << (D) >>

In C++, which one of the following is the extraction or get from operator ?

(A) < (B) > (C) << (D) >>
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15. AqQ¯À¦ Áøµ¯Ö¨¤ø¯ CÆÁõÖ TÓ»õ® :

(A) CÚUSÊ EÖ¨¦ (B) Áøµö¯Àø»

(C) ©µ¦›©® (D) Põs¦ {ø»¨£õ[S

Access specifier is also referred to as :

(A) class member (B) scope

(C) inheritance (D) visibility mode

16. BPO &ß Â›ÁõUP® :

(A) Business Processing Outlet (B) Business Process Outsourcing

(C) Business Process Output (D) Basic Process Outsourcing

BPO - stands for :

(A) Business Processing Outlet (B) Business Process Outsourcing

(C) Business Process Output (D) Basic Process Outsourcing

17. CÁØÖÒ Gx J¸ £vÂß ¦»[PøÍ |À» CøhöÁÎP÷Íõk Põmk® vøµ
BS® ?

(A) ÂÚÁÀ (B) AÔUøP (C) ÁiPmi (D) £iÁ®

Which one of the following is simply a screen that displays the fields of a record in a
well-spaced out manner ?

(A) Query (B) Report (C) Filter (D) Form

18. C++ &À Gs ÁøP CÚ©õØÓ® •ÊUP •ÊUP Gøua \õº¢ux ?

(A) ‰»U SÔ•øÓ (B) C»USU ÷Põ¨¦

(C) C¯US {ø»U÷Põ¨¦ (D) {µÀ ö£¯º¨¤

In C++, integral promotions are purely what oriented ?

(A) source code (B) object file

(C) executable file (D) compiler

19. uµÄzuÍ AmhÁøn°À JÆöÁõ¸ ö|kÁ›ø\²® CÆÁõÖ
AøÇUP¨£kQÓx ?

(A) Á›ø\ (B) ¦»® (C) AmhÁøn (D) £vÄ

In Database Table, each column represents :

(A) Row (B) Field (C) Table (D) Record
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20. ìhõºBL¤ì ÷£êÀ, J÷µ AÀ»x öÁÆ÷ÁÖ uµÄz uµ[PÎß JßÖ
AÀ»x JßÖUS ÷©Ø£mh AmhÁønPÎ¼¸¢x uµÄPøÍ JßÖ ÷\ºUS®
ö\¯Ø£õmøh GÆÁõÖ AøÇUP»õ® ?

(A) ÷uhÀ (B) Á›ø\¯õUP®

(C) ÷\ºzuÀ (D) ÁiPmhÀ

In StarOffice Base, which is a process of joining data from two or more tables of the
same or different database ?

(A) Searching (B) Sorting

(C) Merging (D) Filtering

21. Â]PõÀU (Visicalc) E¸ÁõUP¨£mh Bsk :

(A) 1982 (B) 1999 (C) 1979 (D) 1959

Visicalc was developed in the year :

(A) 1982 (B) 1999 (C) 1979 (D) 1959

22. C++ &À ö\¯ØTÖ £oªS¨¦, ö\¯ØSÔ £oªS¨¦ ‰»® Gx
{øÓ÷ÁØÓ¨£kQÓx ?

(A) Eøµö£õv¯õUP® (B) £À¾¸ÁõUP®

(C) ö\¯ØTÖ (D) ©µ¦›©®

In C++, which is achieved through function overloading and operator overloading ?

(A) Encapsulation (B) Polymorphism

(C) Function (D) Inheritance

23. C++ &À J¸ ©hUQß EhØ£Sv°À Ch® ö£Ö® G¢u PmhøÍ, AuØS¨
¤ß EÒÍ PmhøÍPÒ {øÓ÷ÁØÓ¨£hõ©À ©hUQøÚ Akzu _ÇØ]US
Cmka ö\À¾® ?

(A) continue (B) break (C) return (D) size of

In C++, which statement forces the next iteration of the loop to take place, skipping
any code that follows it ?

(A) continue (B) break (C) return (D) size of
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24. J¸ CÚU SÊÂ¼¸¢x ¤Ó CÚU SÊUPÒ u¸ÂUP¨ £k©õ°ß AuøÚ
CÆÁõÖ AøÇUP»õ® :

(A) Ai¨£øh CÚUSÊ (B) ö£õ¸Ò CÚUSÊ

(C) u¸ÂUP¨£mh CÚUSÊ (D) ö\¯ØTÖ CÚUSÊ

The class from which the other classes are derived is called :

(A) Base class (B) Object class

(C) Derived class (D) Function class

25. ö\¸S® ¦ÒÎø¯ BÁnzvß CÖvUS |PºzxÁuØS AÊzu ÷Ási¯
ö£õzuõßPÒ ¯õøÁ ?

(A) Ctrl + Home (B) Ctrl + End

(C) Shift + Home (D) Shift + End

Which keys are pressed to move the insertion point to the end of a document ?

(A) Ctrl + Home (B) Ctrl + End

(C) Shift + Home (D) Shift + End

26. ¤ßÁ¸® TØÖUS {µÀ ö£¯º¨¤ GßÚ ¤øÇø¯a _mk® :

if(a<b);

cout<<“Greater”;

else

cout<<“Smaller”;

(A) misplaced if (B) misplaced else

(C) misplaced if else (D) statement missing;

What is the error thrown by the compiler for the following snippet ?

if(a<b);

cout<<“Greater”;

else

cout<<“Smaller”;

(A) misplaced if (B) misplaced else

(C) misplaced if else (D) statement missing;
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27. G¢u \õÂa ÷\º©õÚzøu¨ £¯ß£kzv ìhõºBL¥ì C®¨öµì&À
]À¾PøÍ Aa]h»õ® ?

(A) Alt + P (B) Shift + P

(C) Ctrl + P (D) Ctrl + Shift + P

Which key combination is used to print slides in StarOffice Impress ?

(A) Alt + P (B) Shift + P

(C) Ctrl + P (D) Ctrl + Shift + P

28. ìhõºBL¤ì PõÀQÀ G¢u £møh ö\¯Ø£õmi¾ÒÍ ~snøÓ°À EÒÍz
uµÄPøÍ öÁÎUPõmh¨ £¯ß£kQÓx ?

(A) ö£õ¸Ò £møh (B) {ø»¨ £møh

(C) E¸Ò £møh (D) Áõ´¨£õmk¨ £møh

In StarOffice Calc, which bar is used to display the current cell and its contents ?

(A) Object bar (B) Status bar

(C) Scroll bar (D) Formula bar

29. C++ &À, Ao Gß£x G¢u uµÂÚ ÁøP¨£k® ?

(A) u¸ÂUP¨£mh (B) £¯Úº Áøµ¯øÓ

(C) EÒÎøn¢u (D) Pmk¸

In C++, the array belongs to which data type ?

(A) derived (B) user defined

(C) built-in (D) structure

30. CBT - ß Â›ÁõUP® :

(A) Computer Based Tools (B) Computer Based Technique

(C) Computer Based Tutorials (D) Common Based Tutorials

CBT - stands for :

(A) Computer Based Tools (B) Computer Based Technique

(C) Computer Based Tutorials (D) Common Based Tutorials
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31. QuickTime £iÁzvß ÷Põ¨¦PÒ C¢u Â›øÁU öPõskÒÍx :

(A) .snd (B) .mov (C) .swf (D) .wmf

Files in the QuickTime format have the extension :

(A) .snd (B) .mov (C) .swf (D) .wmf

32. G¢u vÓÄU÷PõÀ J¸ uµÄzuÍ AmhÁøn°ß J¸ £vøÁ
uÛzußø©÷¯õk SÔUS® J¸ vÓÄ÷Põ»õS® ?

(A) •ußø© (B) ÁøÍ¯ø©¨¦

(C) JØøÓU ÷Põ¨¦ (D) £i{ø»

Which is a key that uniquely identifies a record in a database table ?

(A) Primary (B) Network

(C) Flat-File (D) Hierarchical

33. uµÄPøÍ²®, ö\¯ØTÖPøÍ²® J¸ ö£õ¸Ò Áøµ¯øÓUSÒ JßÓõP¨
¤ønzx øÁUS® ö\¯À ~m£® CÆÁõÖ AøÇUP¨£kQÓx :

(A) £À¾¸ÁõUP® (B) ö£õ¸Ò

(C) CÚUSÊ (D) EøÓ ö£õv¯õUP®

The mechanism by which the data and functions are bound together within an object
definition is called as :

(A) Polymorphism (B) Object

(C) Class (D) Encapsulation

34. ìhõº BL¤ì øµmh›À G¢u \õÂø¯¨ £¯ß£kzv ö\õØPÎß GÊzx¨
¤øÇø¯ \› ö\´²® Eøµ¯õhÀ ö£miø¯¨ ö£Ó»õ® ?

(A) F7 (B) F6 (C) F5 (D) F4

In StarOffice Writer, which key is pressed to select the spelling check dialog box ?

(A) F7 (B) F6 (C) F5 (D) F4

35. C++ &À Gx J¸ {øÚÁP •PÁ›ø¯ HØS® ©õÔ BS® ?

(A) _mk (B) ©õÔ¼

(C) Pmk¨£õmk PmhøÍ Aø©¨¦ (D) ©hUS

In C++, which is a variable that holds a memory address ?

(A) pointer (B) constant

(C) control structure (D) loop
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36. ¤ßÁ¸ÁÚÁØÖÒ Gx £À¿hPU ÷Põ¨¦PøÍ E¸Áø©UP¨ £¯ß£k®
ö©ßö£õ¸Ò AÀ» ?

(A) Flash (B) Maya

(C) Notepad (D) DreamWeaver

Which one of the following is not a multimedia content development software ?

(A) Flash (B) Maya

(C) Notepad (D) DreamWeaver

37. C++ &À ¤ßÁ¸ÁÚÁØÔÀ Gx CÚUSÊÂß AqQ¯À¦ Áøµ¯Ö¨¤ AÀ» ?

(A) public (B) private (C) pointer (D) protected

In C++, which of the following is not a class access specifier ?

(A) public (B) private (C) pointer (D) protected

38. C++ &À ¤ß Á¸ÁÚÁØÖÒ Gx Áøµö¯Àø» wº©õÛ¨¦a ö\¯ØSÔ BS® ?

(A) : (B) & (C) * (D) ::

In C++, which of the following is a scope resolution operator ?

(A) : (B) & (C) * (D) ::

39. CÁØÖÒ Gx J¸ J¼ £v¨¦ ö©ß ö£õ¸ÍõS® ?

(A) JPEG (B) Vector Graphics

(C) Modeling (D) Sound Forge

Which one of the following is a sound editing program ?

(A) JPEG (B) Vector Graphics

(C) Modeling (D) Sound Forge

40. J¸ Eøµ BÁnzvÀ Calc Cell Á›ø\ JßøÓ ö\¸P EuÄ® PmhøÍ :

(A) Edit → Cut (B) Format → Paste

(C) Edit → Paste Special (D) Edit → Copy

The command to insert a range of Calc Cells into a text document :

(A) Edit → Cut (B) Format → Paste

(C) Edit → Paste Special (D) Edit → Copy
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41. ©¸zxÁ  ̈ö£¯º¨£õÁn® GzuøÚ •ußø©¯õÚ £i {ø»PøÍU öPõshx :

(A) ‰ßÖ (B) Cµsk (C) |õßS (D) I¢x

How many main steps are there in medical transcription ?

(A) three (B) two (C) four (D) five

42. ìhõºBL¤ì ÷£ì&À Eøµz uø»¨¦PøÍU öPõsh Eøµ
BÁnzv¼¸¢x G¢u Cøn¨¦PøÍz ÷uºÄ ö\´uõÀ {PÌzu¾USÒ Eøµ
Á›ø\ø¯a ö\¸P»õ® ?

(A) File → Outline to  Presentation

(B) File → Send → Outline to Presentation

(C) Format → Outline to Presentation

(D) Format → Send → Outline to Presentation

In StarOffice Base, which command is used to insert a text outline into a presentation ?

(A) File → Outline to  Presentation

(B) File → Send → Outline to Presentation

(C) Format → Outline to Presentation

(D) Format → Send → Outline to Presentation

43. ìhõºBL¤ì PõÀUQÀ, uµÄPøÍ GÎuõP ¦›¢x öPõÒÍ EuÄÁx Gx ?

(A) Áõ´¨£õk (B) \õº¦PÒ

(C) ö£õ¸Ò (D) Áøµ£h[PÒ

In StarOffice Calc, which is used to make data easier to understand ?

(A) formula (B) functions

(C) object (D) charts

44. C++ &À £oªSzu ö\¯ØTÖPÒ GÆÁøP¯õÚ AÍ¦¸UPÎß
GsoUøP°÷»õ, AÁØÔß uµÄ CÚ[PÎ÷»õ ÷ÁÖ£mi¸UP ÷Ásk® ?

(A) ö©´¯õÚ (B) •ßÛ¯À¦

(C) SÔ¨¦ (D) •øÓ¯õÚ

In C++, each overloaded function must differ either by the number or their datatype of
which parameters ?

(A) actual (B) default

(C) reference (D) formal



www.ca
re

er
in

dia.
co

m

126733

A A

A A

45. ìhõº BL¤ì øµmh›À J¸ AmhÁøn°À ]ØÓøÓPÐUSÒ •ß¦Ó©õP
|PºÁuØS G¢u ö£õzuõøÚ £¯ß£kzu ÷Ásk® ?

(A) Shift (B) Ctrl (C) Alt (D) Tab

In StarOffice Writer, which key is used to move forward through the cells in the
table ?

(A) Shift (B) Ctrl (C) Alt (D) Tab

46. G¢u ö\¯ØTÖ ö\¯ØTØÔß PmhøÍPÒ •Êø©²® AøÇ¨¦U TØÖUS¨
£v»õP A¨£i÷¯ {µ¼À ö\¸QÂk® ?

(A) void (B) main (C) return (D) inline

Which function inserts the function’s code directly into the calling program ?

(A) void (B) main (C) return (D) inline

47. C++ &À G¢u ©v¨ø£²® v¸¨¤¯Ý¨£õu ö\¯ØTÖ CÆÁõÖ AÔÂUP¨£h
÷Ásk® ?

(A) void (B) int (C) inline (D) main

In C++, the function that returns no value is declared as :

(A) void (B) int (C) inline (D) main

48. G¢u¨ ö£õzuõøÚ AÊzxÁuß ‰»® {PÌzxuø» öuõh[P»õ® ?

(A) F2 (B) F11 (C) F5 (D) F7

Which key is used to start presentation ?

(A) F2 (B) F11 (C) F5 (D) F7

49. CÚUSÊÂß EhØ£Sv CøuU öPõsk •ØÖ¨ ö£ÖQÓx :

(A) , (PõØ¦ÒÎ) (B) : (JØøÓ •UPõØ¦ÒÎ)

(C) . (¦ÒÎ) (D) ; (Aøµ¨¦ÒÎ)

The body of a class is terminated by :

(A) , (comma) (B) : (colon)

(C) . (dot) (D) ; (semicolon)
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50. Gx ußøÚzuõ÷Ú |Pö»kzx¨ ö£¸UQU öPõsk Po¨ö£õÔ°À ÷\ªzx
øÁzxÒÍ uµÄPÐUS®, ÷Põ¨¦PÐUS® £õv¨¦ HØ£kzuU Ti¯x ?

(A) |a_ Gvº¨¤ {µÀ (B) Aµs EøhzuÀ

(C) E›ø©°»õ |P»õUP® (D) |a_ {µÀ

Which is a self-replicating program that can cause damage to data and files stored on
the computer ?

(A) Antivirus (B) Cracking

(C) Piracy (D) Virus

51. ¤ßÁ¸® ©hUS GzuøÚ •øÓ C¯[S® ?

for (m=0; m<6; m++)

(A) 6 (B) 7 (C) 5 (D) 4

How many times the loop will be executed ?

for (m=0; m<6; m++)

(A) 6 (B) 7 (C) 5 (D) 4

52. Pmk¨£õk, {µ¼ß J¸ £Sv°¼¸¢x CßöÚõ¸ £SvUSz uõÄÁuØSU
Põµn©õÚ {µÀ TØÖPÒ CÆÁõÖ AøÇUP¨£kQÓx ?

(A) EÒÏmk (B) öÁÎ±k

(C) Pmk¨£õmkU Pmhø©¨¦PÒ (D) ©v¨¤Özx

Program statements that cause a jump of control from one part of a program to another
are called :

(A) Input (B) Output

(C) Control Structures (D) Assignment

53. ìhõºBL¤ì PõÀUQÀ G¢u SÔø¯U öPõk¨£uß ‰»® A¢u
~snøÓø¯, uÛzu ~snøÓ •PÁ› öPõshuõP BUP •i²® ?

(A) $ (B) # (C) ! (D) &

In StarOffice Calc, which one of the following sign is used to make the cell, absolute
cell address ?

(A) $ (B) # (C) ! (D) &
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54. ÁiPmhÀ Gß£x J¸ ÁøP :

(A) AmhÁøn (B) ÂÚÁÀ (C) £iÁ® (D) AÔUøP

A filter is also a type of :

(A) Table (B) Query (C) Form (D) Report

55. ìhõºBL¤ì PõÀUQÀ Gx J¸ ªSv¯õP¨ £¯ß£kzu¨£k® \õº¦ ?

(A) SQR (B) AVG (C) SUM (D) POW

In StarOffice Calc, which one is the most commonly used function ?

(A) SQR (B) AVG (C) SUM (D) POW

56. ¤ßÁ¸® {µÀ öuõSv°À EÒÍ ©õÔ ‘a’ &ß Áøµö¯Àø» ¯õx ?

if(x>y)

{

int a=x;

a++;

}

(A) ÷Põ¨¦ (B) ö\¯ØTÖ (C) EÒÍø© (D) CÚUSÊ

In the following snippet what is the scope of the variable ‘a’ ?

if(x>y)

{

int a=x;

a++;

}

(A) file (B) function (C) local (D) class

57. ìhõº BL¤ì øµmh›À JßÖUS® ÷©Ø£mh Á›ø\PøÍ ÷\ºUP G¢u
PmhøÍ £¯ß£kQÓx ?

(A) Insert → Table → Rows (B) Table → Insert → Rows

(C) Table → Rows → Insert (D) Format → Rows

In StarOffice Writer, which command is used to insert more than one row in a table ?

(A) Insert → Table → Rows (B) Table → Insert → Rows

(C) Table → Rows → Insert (D) Format → Rows
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58. ìhõºBL¤ì øµmh›À G¢u \õÂ ÷\º©õÚzøu £¯ß£kzv J¸ £zvø¯
ø©¯ Cø\Ä ö\´¯»õ® ?

(A) Ctrl + C (B) Ctrl + A (C) Ctrl + E (D) Ctrl + L

In StarOffice Writer, which key combination is used to center align paragraph ?

(A) Ctrl + C (B) Ctrl + A (C) Ctrl + E (D) Ctrl + L

59. {PÌzxuÀ E¸Áø©UP £¯ß£kÁx Gx ?

(A) ìhõºBL¤ì øµmhº (B) ìhõºBL¤ì PõÀU

(C) ìhõºBL¤ì C®¨öµì (D) ìhõºBL¤ì ÷£ì

Which is used to create presentation ?

(A) StarOffice Writer (B) StarOffice Calc

(C) StarOffice Impress (D) StarOffice Base

60. ìhõºBL¤ì PõÀUQÀ ¤Ó £¯ß£õkPÎ¼¸¢x SÔ¨¦PøÍ
AmhÁøn°À ÷\ºUP CÁØÖÒ G¢u¨ £oUSÔ EuÄQÓx ?

(A) Insert OLE Object (B) Insert Applet

(C) Insert Floating Frame (D) Insert Movie and Sound

In StarOffice Calc, which icon is used to insert objects from other applications into a
worksheet ?

(A) Insert OLE Object (B) Insert Applet

(C) Insert Floating Frame (D) Insert Movie and Sound

61. J÷µö¯õ¸ CÚUSÊøÁ Ai¨£øh¯õPU öPõsk u¸ÂUP¨£mh
CÚUSÊøÁ E¸ÁõUSÁx :

(A) £» ÁÈ ©µ¦›©® (B) J¸ ÁÈ ©µ¦›©®

(C) P»¨¦ ©µ¦›©® (D) £» {ø» ©µ¦›©®

When a derived class inherits only from one base class, it is known as :

(A) Multiple Inheritance (B) Single Inheritance

(C) Hybrid Inheritance (D) Multilevel Inheritance
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62. C++ &À Gx ©õØÓ •i¯õu ©v¨ø£U öPõsh J¸ uµÄ ÂÁµ® BS®.

(A) ©õÔ¼PÒ (B) {ÖzuU SÔPÒ

(C) ]Ó¨¦a ö\õØPÒ (D) SÔ¨ ö£¯ºPÒ

In C++, which are the data items whose values cannot be changed ?

(A) constants (B) punctuators

(C) Keywords (D) Identifiers

63. C++ &À ªP •UQ¯©õÚ £s¦UTÖ :

(A) CÚUSÊ (B) _mk (C) ©õÔ (D) Pmk¸

The most important feature of C++ is the :

(A) class (B) pointer (C) variable (D) structure

64. C++ &À AÈ¨¤°ß ö£¯º G¢u SÔø¯ •ßöÚõmhõP öPõsi¸US® ?

(A) ~ (tilde) (B) + (plus) (C) ++ (increment) (D) ! (NOT)

Which character prefix the destructor name in C++ ?

(A) ~ (tilde) (B) + (plus) (C) ++ (increment) (D) ! (NOT)

65. C++ &À Ao°ß EÖ¨ö£soUøP G¨÷£õx® C¢u GsnõP C¸US® :

(A) ÷uv (B) ÷|º© (C) Gvº© (D) ªuøÁ

In C++, the size of the array should always be :

(A) Date (B) Positive (C) Negative (D) Float

66. uµÄ A¸Á©õUP® Cuß ‰»® \õzv¯©õQÓx :

(A) £À¾¸ÁõUP® (B) ©µ¦›©®

(C) uµÄ ©øÓ¨¦ (D) Ao

Data abstraction is achieved through :

(A) Polymorphism (B) Inheritance

(C) Data Hiding (D) Array
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67. J¸ CÚUSÊÂÀ GzuøÚ AÈ¨¤PÒ Ch® ö£Ó»õ® ?

(A) JßÖ (B) Cµsk (C) ‰ßÖ (D)  |õßS

How many destructor can be given in a class ?

(A) 1 (one) (B) 2 (two) (C) 3 (three) (D)  4 (four)

68. a=5, b=4 ©ØÖ® c=6 GÛÀ ¤ßÁ¸® ÷PõøÁ°ß ©v¨¦, a=a+b/2*c; :

(A) 16 (B) 17 (C) 42 (D) 60

If a=5, b=4 and c=6, the value of the expression a=a+b/2*c; is :

(A) 16 (B) 17 (C) 42 (D) 60

69. ìhõºBL¤ì PõÀUQÀ EÒÍ \©ªßø© (inequality) C¯UQ Gx ?

(A) ! (B) < > (C) = = (D) #

Which is the inequality operator in StarOffice Calc ?

(A) ! (B) < > (C) = = (D) #

70. ¤ßÁ¸ÁÚÁØÖÒ Gx uõÚø©Ä BUQ BS® ?

(A) add(add & x) (B) add( )

(C) add(int x) (D) add(int x, int y)

Which of the following is a default constructor ?

(A) add(add & x) (B) add( )

(C) add(int x) (D) add(int x, int y)

71. void add : : display( ) C¢u GkzxUPõmiÀ CÚUSÊÂß ö£¯º GßÚ ?

(A) void (B) add (C) add : : display( ) (D) display( )

void add : : display( ) in this example what is the name of the class ?

(A) void (B) add (C) add : : display( ) (D) display( )
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72. BÁnzvß öPõhõ {ø» Kµ®, ÷©À £õPzv¾® RÌ £õPzv¾® GzuøÚ
A[S»® C¸US® ?

(A) 1.25 (B) 1 (C) 2 (D) 2.25

The default top, bottom margins in a document should be __________ inches.

(A) 1.25 (B) 1 (C) 2 (D) 2.25

73. Gx öuõhº¦øh¯ uµÄPÒ AÀ»x uPÁÀPÎß öuõS¨ø£U öPõsh J¸
PÍg]¯® BS® ?

(A) ¦»® (B) uµÄzuÍ®

(C) £vÄ (D) £v¨£õ´Ä

Which is a repository of collections of related data or facts ?

(A) Field (B) Database

(C) Record (D) Editing

74. G¢u¨ £iÁ® ]À¾PøÍ E¸ÁõUPÄ®, £v¨¤UPÄ® AÝ©vUQÓx ?

(A) Normal view (B) Outline view

(C) Notes view (D) Handouts view

Which view allows the user to create and edit slides ?

(A) Normal view (B) Outline view

(C) Notes view (D) Handouts view

75. Gx ìhõºBL¥ì C®¨öµêÀ, £» ÁøP¯õÚ J¼, JÎUPõm]U ÷Põ¨¦
ÁiÁø©¨¦PøÍ ÁÇ[P Ch¨£mkÒÍx ?

(A) Media Player (B) Outline (C) Hatching (D) Gradient

Which is embedded in StarOffice Impress to support different audio and video file
formats ?

(A) Media Player (B) Outline (C) Hatching (D) Gradient
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£Sv & II / PART - II

GøÁ÷¯Ý® C¸£x ÂÚõUPÐUS ©mk® K›¸ Á›PÎÀ Âøh¯Î.
Answer any twenty questions in one or two sentences each.

76. ö\õØ ö\¯»õUPÀ GßÓõÀ GßÚ ?
What is meant by Word Processing ?

77. öuõ[S® EÒuÒÍÀ GßÓõÀ GßÚ ?
What is Hanging Indent ?

78. ìhõº BL¤ì PõÀUQÀ ÷uvU PnURk GßÓõÀ GßÚ ?
What is Date Arithmetic in StarOffice Calc ?

79. ìhõº BL¤ì PõÀUQÀ £õºøÁ°k C¯UQPÒ ¯õøÁ ? GkzxUPõmkz
u¸P.
Write a note on reference operator in StarOffice Calc.  Give example.

80. uµÄzuÍ ÷©»õsø© Aø©¨¤ß ö\¯À£õkPÎß ‰ßÖ ö£õx¨¤›ÄPÒ
¯õøÁ ?
What are the three general categories of the data management task ?

81. AÔUøP GßÓõÀ GßÚ ?
What is Report ?

82. JÎUPõm] SÖUS •øÓPøÍ¨ £ØÔ GÊxP.
Write about the types of video compressions.

83. AVI &£iÁ® £ØÔ SÔ¨¦ GÊxP.
Write a note on AVI format.

84. J¸ {PÌzxu¼ß ¤ßÚoø¯ GÆÁõÖ ©õØÓ»õ® ?
How will you change the slide background ?

85. Custom Animation GßÓõÀ GßÚ ?
What is Custom Animation ?

86. ö£õ¸Ò Gß£uß EmP¸zx GßÚ ?
What is the significance of an object  ?

87. £s¦nºzvPÎß ÂøÍÄPÒ £ØÔ SÔ¨¦ ÁøµP.
Write note on impact of modifiers.

20x2=40
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88. ÂÀø»PÒ GßÓõÀ GßÚ ? Auß ÁøP£õkPÒ ¯õøÁ ?
What are tokens ?  What are its types ?

89. break &PmhøÍ°ß £¯ß ¯õx ?
What is the use of break statement ?

90. C++ {µ¼ß ‰ßÖ •UQ¯ ¤›ÄPÒ ¯õøÁ ?
What are the three primary sections of C++ ?

91. return &TØÖ GßÓõÀ GßÚ ?
What is meant by return statement ?

92. Ao GßÓõÀ GßÚ ? Auß ÁøPPÒ ¯õøÁ ?
What is an Array ?  What are its types ?

93. strcmp( ) &\õº¤ß £¯ß ¯õx ?
What is the use of strcmp( ) function ?

94. CÚUSÊÂß Áøµ¯Ö¨¦ £SvPÒ ¯õøÁ ?
What are the specifications of a class ?

95. J¸ CÚUSÊøÁ Áøµ¯Ö¨£uØPõÚ ö£õxÁiÁ® ¯õx ?
Write the general form of class declaration.

96. ö\¯ØTÖ £oªS¨¤À ö\¯ØTÖPÒ GÆÁõÖ C¯UP¨£kQßÓÚ ?
How are functions invoked in function overloading ?

97. BUQ°ß ö\¯À£õkPÒ ¯õøÁ ?
What are the functions of a constructor ?

98. ©µ¦›©zvß £»ßPÒ ¯õøÁ ?
What are the advantages of Inheritance ?

99. AøÇ¨¦uÂ ø©¯® GßÓõÀ GßÚ ?
What is Call Center ?

100. Po¨ö£õÔ SØÓ® GßÓõÀ GßÚ ?
What is Computer Crime ?
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£Sv & III / PART - III

GøÁ÷¯Ý® HÊ ÂÚõUPÐUS ©mk® Âøh¯ÎUPÄ®.

Answer any seven questions.

101. J¸ BÁnzvÀ ÷uøÁ¨£k® Eøµ¨ £Svø¯ _möh¼, Âø\¨£»øP
©ØÖ® SÖUS ÁÈ ‰»® GÆÁõÖ ÷uº¢öukUP»õ® ?

How will you select the required portion of the text in a document using mouse, keyboard
and shortcuts ?

102. ìhõºBL¤ì- øµmh›À AmhÁøn ÁiÅmhÀ P¸Â¨ £møh°À EÒÍ
£oUSÔPÎß ÷Áø»PÒ GßÚ ?

What are the various functions of the icons in the table formatting tool bar in StarOffice
Writer ?

103. ìhõºBL¤ì PõÀUQÀ \õº¦PÒ GßÓõÀ GßÚ ? AÁØøÓ AmhÁønz
uõÎÀ G¨£i £¯ß£kzxÁõ´ ? GkzxUPõmkhß ÂÍUSP.

What are functions (in StarOffice Calc) ?  How will you use them in the worksheet ?
Explain with an example.

104. ìhõºBL¤ì- PõÀUQÀ ö£õ¸Ò ÷\ºzuÀ (Insert Object) uØPõ¼P P¸Â¨
£møh°À EÒÍ £oUSÔPÒ £ØÔ ÂÁ›.

Explain the various icons in the insert object floating tool bar of StarOffice Calc.

105. uµÄzuÍ ÁøPPÒ & ÂÍUSP.

Explain the different types of Database.

106. öÁÎ÷¯ØÓÀ & ÷\õv¨¦ ©hUQøÚ öuõh›¯À (syntax) ©ØÖ®
GkzxUPõmkhß ÂÁ›.

Explain Exit-check loop with syntax and example.

107. SÔ¨¦ ‰»® AøÇzuÀ •øÓø¯ uUP GkzxUPõmkhß ÂÁ›.

Explain call by reference method with suitable example.

108. ö\¯ØSÔ £oªS¨¦ GßÓõÀ GßÚ ? Auß Âv•øÓPøÍ GÊxP.

What is Operator Overloading ? List its rules.

7x5=35



www.ca
re

er
in

dia.
co

m

226733

A A

A A

109. öPõkUP¨£mh öÁÎ±k ö£ÖÁuØS RÌUPsh  C++ {µ¼À Põq®
¤øÇPøÍz v¸zv GÊxP.
Output : (Assume a=15, b=16)
Debug the following C++ program to get the following output :
Output : (Assume a=15, b=16)
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110. ¤ßÁ¸® C++ {µ¼ß öÁÎ±miøÚ GÊxP.
Find the output for the following C++ program.
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